Narvar - USPS Label and Address API Outage – Incident details

All systems operational

USPS Label and Address API Outage

Resolved
Operational
Started 5 months agoLasted about 2 hours

Affected

Returns

Operational from 7:32 PM to 9:51 PM

Updates
  • Resolved
    Resolved

    Hello,

    USPS has resolved the issue with the label and address apis. The issue lasted from approximately 11:00 AM PDT to 2:30 PM PDT.

  • Investigating
    Investigating

    Hello,

    USPS is experiencing an outage with their label and address apis.

    Users initiating return orders through the Narvar Returns Portal may receive an error message that their return cannot be completed at this time. For non Shopify Returns retailers, Narvar will retry the return submission once the outage has been resolved.

    Our team is currently monitoring the situation. Our next update will be at 3:00 PM PDT, or as soon as the issue is resolved.