Narvar - Issue with UPS Label Generation – Incident details

All systems operational

Issue with UPS Label Generation

Resolved
Operational
Started 1 day agoLasted about 2 hours

Affected

Returns

Operational from 7:10 AM to 9:29 AM

Narvar Returns and Exchanges for Shopify

Operational from 7:10 AM to 9:29 AM

Updates
  • Resolved
    Resolved

    The issue with the UPS return label generation failure has been resolved. Customers will be able to place returns now. For more details, please visit the UPS page: https://developer.ups.com/apiDashboard?loc=en_US

  • Monitoring
    Monitoring

    UPS is currently experiencing an issue, which may cause customers to see a return label generation failure when attempting to place a return. The issue started at 11 PM PST. UPS has confirmed that the issue is on their end, and no other carriers are affected.


    For more details, please visit the UPS status page: https://developer.ups.com/apiDashboard?loc=en_US