Narvar - DHL Germany Carrier Outage – Incident details

All systems operational

DHL Germany Carrier Outage

Resolved
Operational
Started 15 days agoLasted about 6 hours

Affected

Returns

Operational from 11:41 AM to 5:23 PM

Updates
  • Resolved
    Resolved

    The DHL Germany carrier outage issue is now resolved. The issue lasted from approximately 4:41:24 PST to 7:15:51 PST

  • Investigating
    Investigating

    Hello,

    DHL-Germany is experiencing an outage at their end, which is impacting Narvar Returns.

    Users initiating return orders through the Narvar Returns Portal may receive an error message that their return cannot be completed at this time.

    Our team is currently monitoring the situation and following up with the carrier for more information. Our next update will be at 11:00 AM PST, or as soon as DHL confirms the issue is resolved.