Scheduled Maintenance Notice – DPD Shipping Platform
Scheduled for June 28, 2025 at 5:00 PM – 6:15 PM
Affects
Returns
Under maintenance from 5:00 PM to 6:15 PM
General Updates / Maintenance
Under maintenance from 5:00 PM to 6:15 PM
Completed
June 28, 2025 at 6:15 PMCompleted
June 28, 2025 at 6:15 PMMaintenance has completed successfully
In progress
June 28, 2025 at 5:00 PMIn progress
June 28, 2025 at 5:00 PMMaintenance is now in progress
Planned
June 28, 2025 at 5:00 PMPlanned
June 28, 2025 at 5:00 PMStatus: Scheduled Maintenance
Start Time: Saturday, June 28, 2025, at 5:00 PM GMT
End Time: Saturday, June 28, 2025, at 6:15 PM GMT
Expected Duration: 1 hour and 15 minutes
Impact:
During this maintenance window, the following services will be unavailable:
MyDPD and web functions will be offline
Users will be unable to log in to DPD
You will not be able to generate return labels through our Return Portal
We recommend planning accordingly to minimize any disruptions to your operations.
We appreciate your understanding and patience during this maintenance period.
For questions or assistance, please contact Narvar Support.