Narvar - Canada Post Service Disruption – Incident details

All systems operational

Canada Post Service Disruption

Resolved
Degraded performance
Started 12 days agoLasted about 7 hours

Affected

Carriers

Degraded performance from 10:37 PM to 5:32 AM

Updates
  • Resolved
    UTC
    Resolved

    Canada Post has confirmed this issue is resolved.

  • Investigating
    UTC
    Investigating

    We are currently observing a service disruption affecting multiple Canada Post services. We have reached out to Canada Post for more information.