Narvar - Issue with Canada Post return labels – Incident details
All systems operational
Issue with Canada Post return labels
Resolved
Degraded performance
Started 2 days agoAugust 07, 2026Lasted about 2 hoursAugust 07, 20262:454:22 PMUTC
Affected
Returns
Degraded performance from 2:45 PM to 4:22 PM
Updates
Resolved
UTC
Resolved
UTC
Canada Post return label generation has been restored and we are seeing labels generate successfully. Canada Post has confirmed the underlying issue is resolved.
Investigating
UTC
Investigating
UTC
We are currently observing a service disruption affecting Canada Post return labels. We are actively investigating this and have reached out to Canada Post for more information.