All systems operational

Resolved
Email Delivery Issues for iCloud Email Addresses

Started
November 17, 2023 at 5:31 PM
Status
Resolved after 4 days

Impact

Operational
Affected
Notify
  • Resolved
    Resolved

    Hello,

    We would like to inform you that the issue related to email delivery issues for iCloud email addresses is resolved.

    Please let us know if you continue to observe any issues, receiving emails to iCloud email addresses.
    For more information, please don't hesitate to reach out to Narvar Support by submitting a request here.

    Best regards,
    Narvar Support

  • Investigating
    Update

    Hello,

    We would like to inform you that we are currently experiencing an issue with the Narvar Notify product, specifically related to email delivery issues for iCloud email addresses. Our engineering team is actively investigating the root cause and is diligently working to resolve the matter.

    Sincerely,
    Narvar Support

  • Investigating
    Investigating

    Hello,
    We would like to inform you that we are currently experiencing an issue with the Narvar Notify product, specifically related to email delivery issues for iCloud email addresses. Our engineering team is actively investigating the root cause and is diligently working to resolve the matter.
    Our next scheduled update will be at 2 PM PDT, or as soon as the issue is successfully addressed.
    Thank you for your understanding.
    Sincerely,
    Narvar Support