All systems operational

Issue with UPS Return Drop-Off Locations

Resolved
Degraded performance
Started 12 months ago Lasted about 2 hours

Affected

Returns
Updates
  • Resolved
    Resolved

    Hello,

    We would like to inform you that the issue with UPS return drop-off locations not displaying has been resolved. The issue occurred between approximately 10:00 AM PDT and 2:00 PM PDT.

    For more information, contact Narvar Support by emailing support@narvar.com.

    Sincerely,
    Narvar Support

  • Identified
    Identified

    Hello,

    We are currently observing an issue with UPS drop-off locations. Users are seeing no available locations when attempting to initiate a return, and may be unable to proceed when selecting mail as the return method. Our engineering team has identified the cause, and is working to resolve the issue. Our next update will be at 2:00 PM PDT, or as soon as the issue is resolved.

    Sincerely,
    Narvar Support

  • Investigating
    Investigating

    Hello,

    We are currently observing an issue with UPS drop-off locations. Users are seeing no available locations when attempting to initiate a return, and may be unable to proceed when selecting mail as the return method. Our engineering team is actively investigating the cause and working to resolve the issue. Our next update will be at 1:00 PM PDT, or as soon as the issue is resolved.

    Sincerely,
    Narvar Support