All systems operational

Issue with Mail Return Drop-Off Locations

Resolved
Degraded performance
Started 10 months ago Lasted about 2 hours

Affected

Returns
Updates
  • Resolved
    Resolved

    Hello,

    We would like to inform you that the issue with our return locations service where users were unable to see locations while attempting to initiate a return has been resolved. The issue occurred on July 6th, approximately between 2:30 PM PDT and 5:00 PM PDT.

    For more information, please contact Narvar Support by submitting a request here.

  • Investigating
    Investigating

    Hello,

    We are currently experiencing an issue with our return location's service. Users are seeing no available locations when attempting to initiate a return and may be unable to proceed when selecting mail as the return method. Customers will still be able to submit returns using other methods such as in-store.

    Our engineering team has identified the cause and is working to resolve the issue. Our next update will be at 9:00 PM PDT, or as soon as the issue is resolved.

    Sincerely,
    Narvar Support