All systems operational

Narvar Return Submit Issues

Resolved
Degraded performance
Started 6 months ago Lasted 23 minutes

Affected

Returns
Updates
  • Resolved
    Resolved

    Hello,

    The operational issue that was causing issues when submitting a return has been resolved.

    Sincerely,
    Narvar Support

  • Identified
    Identified

    Hello,

    We are currently observing an operational issue that is causing issues when submitting a return. Our team is actively investigating the cause and working to resolve the issue.
    Our next update will be at 06:00 PM PST, or as soon as the issue is resolved.

    For more information, please contact Narvar Support by submitting a request here.

    Sincerely,
    Narvar Support