All systems operational

Issue with USPS Printerless Label Generation

Resolved
Operational
Started 3 months ago Lasted about 2 hours

Affected

Returns
Updates
  • Resolved
    Resolved

    Hello,

    The issue affecting USPS printerless returns has been resolved. The issue began at approximately 4:25 PM PST, and ended at approximately 9:50 PM PST.

    For more information, please don't hesitate to reach out to Narvar Support by submitting a request here.

    Sincerely,
    Narvar Support

  • Monitoring
    Monitoring

    Hello,

    USPS is currently experiencing an issue with their Label Broker service. Customers attempting a return using USPS printerless will be able to complete their return through a shipping label.

    Our team is monitoring the situation and we have reached out to USPS to resolve the issue.