Narvar - Issues with FedEx Commercial Returns services – Incident details

All systems operational

Issues with FedEx Commercial Returns services

Resolved
Degraded performance
Started 5 days agoLasted about 2 hours

Affected

Returns

Degraded performance from 5:50 PM to 7:43 PM

Updates
  • Resolved
    Resolved

    After deploying a fix, we can see returns being processed as expected and confirm that the issue with Concierge returns via FedEx is now resolved. We will continue to monitor closely to ensure stability.

    Impact was limited to Concierge returns via FedEx. Other carriers and Narvar services remained unaffected.

    Thank you for your patience and understanding while we worked to resolve this.

  • Identified
    Identified

    We have identified the issue and are working to deploy a fix.

  • Investigating
    Investigating

    We are currently investigating an issue with Narvar Concierge returns processed via FedEx following the recent scheduled maintenance performed by FedEx. This may result in delays or disruptions in return processing for some retailers.

    Please note that this incident is limited to Concierge returns via FedEx and does not affect other carriers or Narvar services.

    We will continue to monitor the situation closely and provide timely updates as more information becomes available.