Narvar - Royal Mail — Tracking Service Degraded – Incident details

All systems operational

Royal Mail — Tracking Service Degraded

Resolved
Operational
Started 1 day agoLasted about 3 hours

Affected

Track

Operational from 12:29 PM to 3:33 PM

Updates
  • Resolved
    Resolved

    Royal Mail has confirmed that the tracking issue has been resolved. Tracking updates are now processing as expected, and all services are operating normally. Thank you for your patience while we worked with Royal Mail to resolve this.

  • Update
    Update

    Royal Mail continues to investigate this issue and there is no ETA yet. We will keep the incident update as we hear back from engineering

  • Investigating
    Investigating

    Royal Mail is currently experiencing technical issues affecting its tracking service, causing delays or missing tracking updates.
    Only the tracking functionality is impacted. All other services remain operational. Our teams are monitoring the issue and will share an update once Royal Mail fixes it.