Narvar - Return submissions using the DHL pickup method are currently failing. – Incident details
All systems operational
Return submissions using the DHL pickup method are currently failing.
Resolved
Degraded performance
Started about 1 month agoLasted 7 minutes
Affected
Returns
Degraded performance from 7:24 AM to 7:31 AM
Updates
Resolved
Resolved
This incident has been resolved.
Identified
Identified
Return submissions using the DHL pickup method are currently failing, and customers are unable to generate a return. Our engineering team is actively investigating the issue to identify the root cause and restore normal functionality.