Narvar - Issues with Canada Post Returns – Incident details

All systems operational

Issues with Canada Post Returns

Resolved
Operational
Started 7 days agoLasted about 3 hours

Affected

Carriers

Operational from 11:48 PM to 3:08 AM

Updates
  • Resolved
    Resolved

    We are no longer seeing issues with Canada Post returns. Label generation is now functioning as expected. We will continue to follow up with Canada Post for more information. Please reach out to Narvar Support if there are any questions.

  • Investigating
    Investigating

    Canada Post is currently experiencing issues that are impacting Narvar Returns. We have reached out to the carrier and will provide more information as it becomes available.