Narvar - Return label generation failures with USPS – Incident details

All systems operational

Return label generation failures with USPS

Resolved
Degraded performance
Started about 1 month agoLasted about 10 hours
Updates
  • Resolved
    Resolved

    USPS return labels are now operating as expected. The issue has been resolved.

  • Monitoring
    Monitoring

    We have started to observe service restored for USPS return labels and will continue to monitor closely.

  • Update
    Update

    We continue to actively investigate the service disruption impacting USPS returns and are working closely with USPS toward resolution. We will provide updates as more information becomes available.

  • Investigating
    Investigating

    We are currently experiencing a service disruption impacting USPS returns. This appears to be an issue on the USPS side. Our team is actively coordinating with USPS to investigate and resolve the issue.

    We will share updates as more information becomes available.