Narvar - Intermittent USPS Return Label Timeouts – Incident details

All systems operational

Intermittent USPS Return Label Timeouts

Resolved
Degraded performance
Started 1 day agoLasted about 2 hours

Affected

Carriers

Degraded performance from 6:52 PM to 8:34 PM

Updates
  • Resolved
    Resolved

    USPS has confirmed they have resolved the issue, and we are seeing labels being generated normally.

  • Identified
    Identified

    Our team is in communication with the carrier, and we are currently monitoring all updates from them.

  • Investigating
    Investigating

    We are experiencing intermittent timeout errors being returned by USPS. We have reached out to the USPS team and will provide another update as soon as more information is available.