Started 4 months agoApril 12, 2026Lasted about 1 hourApril 12, 20265:156:00 AMUTC
Affected
Carriers
Degraded performance from 5:15 AM to 6:00 AM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Investigating
UTC
Investigating
UTC
We are currently experiencing errors with FedEx Printerless returns. We have reached out to the FedEx team and will provide another update as soon as more information is available.