Narvar - Issue with FedEx return labels – Incident details

All systems operational

Issue with FedEx return labels

Resolved
Degraded performance
Started 8 days agoLasted about 4 hours

Affected

Returns

Degraded performance from 9:55 PM to 1:48 AM

Updates
  • Resolved
    UTC
    Resolved

    FedEx has confirmed the issue is resolved and we are seeing return labels generating successfully.

  • Identified
    UTC
    Identified

    FedEx has acknowledged the issue and is actively working on a fix.

  • Investigating
    UTC
    Investigating

    We are currently observing issues affecting FedEx return labels. We have escalated to FedEx and are investigating on our side in parallel.